• The SH Membership has gone live. Only SH Members have access to post in the classifieds. All members can view the classifieds. Starting in 2020 only SH Members will be admitted to the annual hunting contest. Current members will need to follow these steps to upgrade: 1. Click on your username 2. Click on Account upgrades 3. Choose SH Member and purchase.
  • We've been working hard the past few weeks to come up with some big changes to our vendor policies to meet the changing needs of our community. Please see the new vendor rules here: Vendor Access Area Rules

Campark T45 Trail Camera Inquiry

WildlifeOps

New Member
Joined
Apr 25, 2022
Messages
1
Hi all,

I'm new to the forum but thought this would be a good place to gather some information regarding some hiccups I've come across with my recent trail camera purchase.

Several months ago I purchased 8 of the Campark T45 trail cameras after hearing of them being a pretty reliable camera for being on the cheaper side. The first week I had them running they all worked great and took quality photos. However, I started running into a problem by the second week and for the next month afterwards, where all but 2 of the cameras would stop taking/recording photos to the micro SD card seemingly randomly at some point between me starting up the camera and then revisiting the site to check them each week. For example, after checking the SD cards at the end of each week, I would find photos of me adjusting the camera on day one, walking away from the site, and then maybe a day or two of animal activity and then nothing more.

I am sure this is not a lack of animal activity crossing the sensors, as there were clear signs of disturbance at some sites, but no photos. Also, the save files lacked any photos of myself walking up to the camera upon each check and I always attempt to trigger the camera on check days to ensure the camera is still working. Lastly, I have the cameras set to 3-shot burst and there were times I counted the amount of photos, and there would only be 1 or 2 photos at a time stamp, when there should be 3. So it seems that at some point during the week (usually between 1-3 days after re-set) the camera is either not taking photos at all, or not recording properly to the SD card. The SD cards are 32 GB, and this would happen between 90-300 photos, so I know the SD cards are not full either.

Note: After each time I "re-set" the camera every week, the cameras would begin taking photos like normal, but then after another 1-3 days, there would not be any more photos recorded, nor photos of me walking up to the set.

I am curious if anyone else has had an issue like this or similar, or if anyone has any tips or solutions.

Thanks for any help you can provide!
 

philsanchez76

Well-Known Member
SH Member
Joined
May 20, 2019
Messages
1,004
Location
TN
I've had 2 camparks. one is 3 years old and still going strong with no issues. the other had issues out of the box. campark did send me a brand new one no questions asked and now that one is also working great 18 months later. id try that first. Guessing their quality control is probably very hit or miss since they are cheap Chinese products.
 
Top