• The SH Membership has gone live. Only SH Members have access to post in the classifieds. All members can view the classifieds. Starting in 2020 only SH Members will be admitted to the annual hunting contest. Current members will need to follow these steps to upgrade: 1. Click on your username 2. Click on Account upgrades 3. Choose SH Member and purchase.
  • We've been working hard the past few weeks to come up with some big changes to our vendor policies to meet the changing needs of our community. Please see the new vendor rules here: Vendor Access Area Rules

First Tactacam pics

Tapeworm

Well-Known Member
Joined
Feb 19, 2018
Messages
1,649
Sucks that even fellow hunters have to be a-holes and can’t just mind their own business

I’ve shown up to my tree at 530am only to find that somebody cut my lock and stole my stand the evening before

1 wma had a guy that was seen carrying boltcutters sticking out of his backpack

Haven’t had a cam stolen yet but have got pics of a private property neighbor attempting to poach with a rifle on my buddy’s horse farm property during bow season

He should have stolen the camera


Sent from my iPhone using Tapatalk
 
Last edited:

DRR324

New Member
Joined
Jan 23, 2020
Messages
17
Looks like 2 different guys to me. One with an orange collar shirt and climber, the othe wearing an orange vest and carrying blind type material. Thinking the vest guy didnt even see the cam...
 

PEEJAY

Well-Known Member
SH Member
Joined
Nov 24, 2019
Messages
1,107
Location
In a van down by the river
Looks like 2 different guys to me. One with an orange collar shirt and climber, the othe wearing an orange vest and carrying blind type material. Thinking the vest guy didnt even see the cam...
The older guy holding the POS bow/climber is the one did it. thats his son im assuming by the age difference. i got a lot more pics on the card that tells the whole story (including over 800 of leaves blowing because it landed facing up). the dad points out the camera then climbs the tree next to it. next day dad n son both came back but dad decided to be a huge prick n couldnt resist himself. i hunt there at least a couple times a week so im sure ill have the pleasure to finally meet him. he didnt hunt today or yesterday :sunglasses:
 

backstrap19

Well-Known Member
Joined
Mar 28, 2019
Messages
339
Nvm...good man! Pretty sure he peeked at my card or at least hunted that tree. I know he got down too early wherever he was hunting. They dont show up there til sunset on the nose. Haha first hunter ive ever seen there. I wish he didnt lay scent down everywhere....nothin but does n a small 8 have been around anywayView attachment 36327
You have two different guys on there, right?
 

buckwalleye

Member
Joined
Jul 15, 2018
Messages
63
Just had my first issue with my reveals. One of them the pictures have been super hazy. At first I thought it was fog/weather. Kept getting worse. Couldn't even see pictures on clear weather. Went to check on it today and the lens was full of moisture. Had to go back to the house to get a tiny screwdriver and go back to the cam. Took out the 4 tiny screws on the inside corners and removed the screen section. There was a lot of water in there (enough to drip out - a few teaspoons worth). I noticed there was a little wire that's supposed to be tucked inside there that was pinched and sticking out, and compromising the seal....only thing I can think of at least. Still odd that much moisture was able to pass through the rubber gasket that snap-hinges shut. Anyone else have this happen? I called tactacam (left a message after being on hold for 12 minutes).


Sent from my SM-G950U using Tapatalk
 

EricS

Well-Known Member
Vendor Rep
SH Member
Joined
Dec 14, 2016
Messages
5,078
Location
Georgia
Just had my first issue with my reveals. One of them the pictures have been super hazy. At first I thought it was fog/weather. Kept getting worse. Couldn't even see pictures on clear weather. Went to check on it today and the lens was full of moisture. Had to go back to the house to get a tiny screwdriver and go back to the cam. Took out the 4 tiny screws on the inside corners and removed the screen section. There was a lot of water in there (enough to drip out - a few teaspoons worth). I noticed there was a little wire that's supposed to be tucked inside there that was pinched and sticking out, and compromising the seal....only thing I can think of at least. Still odd that much moisture was able to pass through the rubber gasket that snap-hinges shut. Anyone else have this happen? I called tactacam (left a message after being on hold for 12 minutes).


Sent from my SM-G950U using Tapatalk
Mine was leaking and had moisture in it and they replaced it. Like called me at the house on a Sunday afternoon and handled it. Couldn’t ask for better customer service.
 

Bowhntr69

New Member
SH Member
Joined
Nov 16, 2020
Messages
9
I have a Reveal, I used regular Duracell batteries and the camera has been out over a month with me getting 30+ pics some days and it is showing that I still have 80% battery life. I am really impressed with the quality of night time pics.
 

Aaronpaul14

Well-Known Member
SH Member
Joined
Nov 9, 2018
Messages
1,192
Location
67074
I have a Reveal, I used regular Duracell batteries and the camera has been out over a month with me getting 30+ pics some days and it is showing that I still have 80% battery life. I am really impressed with the quality of night time pics.
I installed mine Sept 26th and it says it still has 90% battery. One thing I really love, being in Kansas, is a lot less “wind” pictures than any other camera I’ve had! There is a reason they can’t keep them on the shelves!
 

PEEJAY

Well-Known Member
SH Member
Joined
Nov 24, 2019
Messages
1,107
Location
In a van down by the river
I have a Reveal, I used regular Duracell batteries and the camera has been out over a month with me getting 30+ pics some days and it is showing that I still have 80% battery life. I am really impressed with the quality of night time pics.
I noticed this too... and then its dead. Happened on 2 of mine already
 

EricS

Well-Known Member
Vendor Rep
SH Member
Joined
Dec 14, 2016
Messages
5,078
Location
Georgia
Mine has been in the woods since mid September and I just changed the batteries. They text me and sent me an email about it. Was getting a hundred plus pics a day until the first of November. Now it’s just a couple dozen pics of the same two little bucks all day and night. I think they are annoying everything else to the point they have the little block of woods to themselves.
 

kenn1320

Well-Known Member
Joined
Sep 15, 2015
Messages
2,616
Daughter watched 2 deer in front of my cam for a few minutes, no pics. We bumped deer past another cam one morning, nothing. My buddy has similar situations. Im happy with the quality of pics, but I question how many deer it misses. Its fun for the price.
 

PEEJAY

Well-Known Member
SH Member
Joined
Nov 24, 2019
Messages
1,107
Location
In a van down by the river
Daughter watched 2 deer in front of my cam for a few minutes, no pics. We bumped deer past another cam one morning, nothing. My buddy has similar situations. Im happy with the quality of pics, but I question how many deer it misses. Its fun for the price.
My dad bought 2 and has had them up on a lease for 2 months now with 3 pictures total. I dont know whats going on.
 

Bwhana

Well-Known Member
SH Member
Joined
Dec 8, 2017
Messages
1,810
Location
Hickory, NC
Caution - I updated mine with the new firmware today and it bricked it. It went just like their instructions and video all the way to the point you power it off after the update and switch out cards. When I tried going into setup or run mode after that, I get nothing but black screen and no pics. I have contacted them for support, but they are a M-F shop and I am on scouting/hunt trip until Tuesday. Not happy with this development. I will also share that several folks I know have had an issue where the antennae is breaking internally where it screws onto the base, causing no pics to send out. I stand by my philosophy that I don't give companies 2nd chances, so I may have one for sale soon, assuming they replace or fix it.


Update - after talking with staff, this is happening to other cameras too and they have to be sent in to flash the firmware or be replaced. They were told on their team call to process them the same day they are received and ship back out, so at least they are prioritizing the fixes.
 
Last edited:

woodsdog2

Well-Known Member
SH Member
Joined
Jun 28, 2019
Messages
1,031
Caution - I updated mine with the new firmware today and it bricked it. It went just like their instructions and video all the way to the point you power it off after the update and switch out cards. When I tried going into setup or run mode after that, I get nothing but black screen and no pics. I have contacted them for support, but they are a M-F shop and I am on scouting/hunt trip until Tuesday. Not happy with this development. I will also share that several folks I know have had an issue where the antennae is breaking internally where it screws onto the base, causing no pics to send out. I stand by my philosophy that I don't give companies 2nd chances, so I may have one for sale soon, assuming they replace or fix it.
Dang, I was thinking about getting one of these some time.... is your recommendation "No" at this point?
 

EricS

Well-Known Member
Vendor Rep
SH Member
Joined
Dec 14, 2016
Messages
5,078
Location
Georgia
Caution - I updated mine with the new firmware today and it bricked it. It went just like their instructions and video all the way to the point you power it off after the update and switch out cards. When I tried going into setup or run mode after that, I get nothing but black screen and no pics. I have contacted them for support, but they are a M-F shop and I am on scouting/hunt trip until Tuesday. Not happy with this development. I will also share that several folks I know have had an issue where the antennae is breaking internally where it screws onto the base, causing no pics to send out. I stand by my philosophy that I don't give companies 2nd chances, so I may have one for sale soon, assuming they replace or fix it.
Mine had water damage and they replaced it. They actually contacted me on a Sunday after I submitted a complaint on Saturday. While they seem to be having some issues, I really think it’s cell cameras in general. I know prop who have had problems with spy point, stealth, Spartan, Moultrie, and covert. The antenna does feel a little fragile for what it’s meant to do. I do think when a company makes something it should function as advertised. Regardless of price point.
At the same time I feel like we but an 800 dollar phone and spend almost as much as the price of the cell cam for a case to put it in.
 

buckwalleye

Member
Joined
Jul 15, 2018
Messages
63
Update on mine.... I took it apart and dried it all out - hung it by garage heater for a day. Seemed to clear that up. Coincidentally, the IR filter was "stuck" (according to customer service). It was taking night pictures during the day - they all looked black and white. They sent me a new camera. While the new camera was in transit, the camera with the stuck ir filter magically started working correctly again. Customer service said that can happen. So now I got an additional camera (had to buy replacement they sent). Decent customer service. I called one day, on hold for 15 minutes. Left detailed voicemail. No return call. Sent email. Reply took 2 days. And every corresponding reply took a day or 2 on their end - which made for a couple week ordeal, but I imagine they're busy this time of year.

Sent from my SM-G950U using Tapatalk
 

kelly.jayp

Well-Known Member
Joined
Aug 23, 2017
Messages
1,469
Location
Charlotte, NC area
Caution - I updated mine with the new firmware today and it bricked it. It went just like their instructions and video all the way to the point you power it off after the update and switch out cards. When I tried going into setup or run mode after that, I get nothing but black screen and no pics. I have contacted them for support, but they are a M-F shop and I am on scouting/hunt trip until Tuesday. Not happy with this development. I will also share that several folks I know have had an issue where the antennae is breaking internally where it screws onto the base, causing no pics to send out. I stand by my philosophy that I don't give companies 2nd chances, so I may have one for sale soon, assuming they replace or fix it.


Update - after talking with staff, this is happening to other cameras too and they have to be sent in to flash the firmware or be replaced. They were told on their team call to process them the same day they are received and ship back out, so at least they are prioritizing the fixes.
Ugh. I have an sd card prepped to do the firmware update. Guess I will wait it out - I do have one of my two cameras that is not capturing pictures consistently- walked right in front of it for 30 yards in day light and nothing then walked in front of it from the side at night leaving and it took one. I get maybe one pic a day on that camera and there are tracks everywhere in front of it


Sent from my iPhone using Tapatalk
 

Bwhana

Well-Known Member
SH Member
Joined
Dec 8, 2017
Messages
1,810
Location
Hickory, NC
Ugh. I have an sd card prepped to do the firmware update. Guess I will wait it out - I do have one of my two cameras that is not capturing pictures consistently- walked right in front of it for 30 yards in day light and nothing then walked in front of it from the side at night leaving and it took one. I get maybe one pic a day on that camera and there are tracks everywhere in front of it


Sent from my iPhone using Tapatalk
The firmware brick is not a problem for most, but common enough for them to discuss it and plan for it. I woukd update the camera that is not working as well as my guinea pig! I have found their sensors are focused a little different than other brands and had to adjust the angle more on the tree when i install them, yours may be related.
 
Last edited:

kelly.jayp

Well-Known Member
Joined
Aug 23, 2017
Messages
1,469
Location
Charlotte, NC area
Thr firmware brick is not a problem for most, but common enough for them to discuss it and plan for it. I woukd update the camera that is not working as well as my guinea pig! I have found their sensors are focused a little different than other brands and had to adjust the angle more on the tree when i install them, yours may be related.
Good point. Not much to risk there


Sent from my iPhone using Tapatalk
 
Top